前端之家收集整理的这篇文章主要介绍了
【数据结构】第1周 线性表 2:字符串插入,
前端之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
2:字符串插入
-
总时间限制:
-
1000ms
-
内存限制:
-
65536kB
-
描述
-
有两个字符串str和substr,str的字符个数不超过10,substr的字符个数为3。(字符个数不包括字符串结尾处的'\0'。)将substr插入到str中ASCII码最大的那个字符后面,若有多个最大则只考虑第一个。
-
输入
-
输入包括若干行,每一行为一组测试数据,格式为
str substr
-
输出
-
对于每一组测试数据,输出插入之后的字符串。
-
样例输入
-
abcab eee
12343 555
-
样例输出
-
abceeeab
12345553
# include<stdio.h>
# include<string.h>
int main(void)
{
char s1[11],s2[4];
int i;
while(scanf("%s%s",s1,s2)!=EOF)
{
int max=0;
int len=strlen(s1);
for(i=0; i<len; i++)
{
if(s1[i]>s1[max])
{
max=i;
}
}
for(i=0; i<=max; i++)
printf("%c",s1[i]);
printf("%s",s2);
for(i=max+1; i<len; i++)
printf("%c",s1[i]);
printf("\n");
}
return 0;
}
原文链接:https://www.f2er.com/datastructure/383181.html