HDU 2024

前端之家收集整理的这篇文章主要介绍了HDU 2024前端之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。

C语言合法标识符

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27809Accepted Submission(s): 11163


Problem Description
输入一个字符串,判断其是否是C的合法标识符。

Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。

Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。

Sample Input
  
  
3 12ajf fi8x_a ff ai_2

Sample Output
  
  
no yes no
package hdu2024;

import java.io.BufferedInputStream;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {

		Scanner cin = new Scanner(new BufferedInputStream(System.in));
		String s = "^[a-zA-Z|$|_]\\w+$";

		int count = cin.nextInt();
		String str = cin.nextLine();
		for (int i = 0; i < count; i++) {

			str = cin.nextLine();
			if (str.matches(s)) {
				System.out.println("yes");
			} else {
				System.out.println("no");
			}
		}
	}
}
原文链接:https://www.f2er.com/regex/362712.html

猜你在找的正则表达式相关文章