前端之家收集整理的这篇文章主要介绍了
回文数,
前端之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
/**
题目详情:
Njzy学习了回文串后联想到了回文数,他希望统计出一个区间内的所有回文数。
现在给定一个闭区间[a,b],求这个区间里有多少个回文数。
比如[20,30],只有一个回文数那就是22.
输入描述:
输入包含多组测试数据,每组测试数据包含两个整数a,b,(0<a<=b<10^6)。
输出描述:
对于每组测试数据输出相应的答案。
答题说明:
输入样例:
1 10 20 30 300 400
输出样例:
9 1 10
**/
class Program
{
//判断是否回文串
static bool IsHuiWen(string str)
{
int len = str.Length - 1;
for (int i = 0; i <= len; i++)
{
if (str[i] != str[len - i])
return false;
}
return true;
}
static void Main(string[] args)
{
string input = Console.ReadLine();
string pattern = @"(\d+) +(\d+)";
//正则提取用户输入的多组数据
MatchCollection matchColl = Regex.Matches(input,pattern);
foreach (Match item in matchColl)
{
string strNum1 = item.Groups[1].Value;
string strNum2 = item.Groups[2].Value;
if (strNum1.Length == 0 || strNum1.Length == 7)
return;
for (int i = int.Parse(strNum1); i < int.Parse(strNum2); i++)
{
if (IsHuiWen(i + ""))
{
Console.WriteLine(i);
}
}
}
}
}
原文链接:https://www.f2er.com/regex/361611.html