hdu 3449 Consumer 依赖背包~~

前端之家收集整理的这篇文章主要介绍了hdu 3449 Consumer 依赖背包~~前端之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。

Consumer

Time Limit: 4000/2000 MS (Java/Others)Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 1404Accepted Submission(s): 733


Problem Description
FJ is going to do some shopping,and before that,he needs some Boxes to carry the different kinds of stuff he is going to buy. Each Box is assigned to carry some specific kinds of stuff (that is to say,if he is going to buy one of these stuff,he has to buy the Box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping,he intends to get the highest value with the money.

Input
The first line will contain two integers,n (the number of Boxes 1 <= n <= 50),w (the amount of money FJ has,1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith Box 1<=pi<=1000),mi (1<=mi<=10 the number goods ith Box can carry),and mi pairs of numbers,the price cj (1<=cj<=100),the value vj(1<=vj<=1000000)

Output
For each test case,output the maximum value FJ can get

Sample Input
  
  
3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60

Sample Output
  
  
210
上一个博客吧:
http://www.cnblogs.com/wuyiqi/archive/2011/11/26/2264283.html

代码
#include <stdio.h>
#include <string.h>
#define MAX 100100

int dp[55][MAX] ;

int max(int a,int b)
{
	return a>b?a:b ;
}
int main()
{
	int n,sum ;
	while(~scanf("%d%d",&n,&sum))
	{
		memset(dp,sizeof(dp)) ;
		for(int i = 1 ; i <= n ; ++i)
		{
			int p,t;
			scanf("%d%d",&p,&t);
			for(int j = 0 ; j <= p ; ++j)
			{
				dp[i][j] = -1 ;
			}
			for(int j = p ; j <= sum ; ++j)
			{
				dp[i][j] = dp[i][j-p] ;
			}
			for(int j = 0 ; j < t ; ++j)
			{
				int c,v ;
				scanf("%d%d",&c,&v) ;
				for(int k = sum ; k >= v ; --k)
				{
					if(dp[i][k] != -1)
					{
						dp[i][k] = max(dp[i][k],dp[i][k-c]+v) ;
					}
				}
			}
			for(int j = 0 ; j < sum ;++j)
			{
				dp[i][j] = max(dp[i-1][j],dp[i][j]) ;
			}
		}
		printf("%d\n",dp[n][sum]) ;
	}
	return 0 ;
}

与君共勉
原文链接:https://www.f2er.com/javaschema/284903.html

猜你在找的设计模式相关文章